Dのトランク

行く宛もない土日のギャンブラー 馬を見た日から 今日まで走った

RをRubyから使うためのライブラリrsrubyをインストール(Fedora22)

MacとかUbuntuとかはあるんだけどCentOSとかfedraの例がないので苦労した。

Rのインストール

# dnf -y install R


/usr/bin/R
/usr/lib64/R に入るらしい。
rsrubyをインストールするときに使う。

rsrubyのインストール

# gem install rsruby -- --with-R-lib=/usr/lib64/R/lib --with-R-include=/usr/lib64/R/include
Fetching: rsruby-0.5.1.1.gem (100%)
Building native extensions with: '--with-R-lib=/usr/lib64/R/lib --with-R-include=/usr/lib64/R/include'
This could take a while...
Successfully installed rsruby-0.5.1.1
Parsing documentation for rsruby-0.5.1.1
Installing ri documentation for rsruby-0.5.1.1
Done installing documentation for rsruby after 0 seconds
1 gem installed
#


これで、動かせるかと思うとまだ足りないと言われる。

$ ruby rsruby-test-01.rb
Fatal error: R home directory is not defined
$


R_HOMEのセット
.bash_profileに追記
-------
R_HOME=/usr/lib64/R
export R_HOME
-------

$ source .bash_profile


テスト用プログラムを動かしてみる。

$ ruby rsruby-test-02.rb
-0.06888339534691494,1.7816984138790224,-0.050063717160079325,0.30626638838968945,-0.3935390152046732,0.8538004301965689,-0.8239769014809141,-0.7024643100217765,-0.06869084215895659,-0.1288918186828257


うまくいったみたいだ。

参考)
http://learningr.hatenablog.com/entry/2012/01/07/172802
  1. 2016/01/07(木) 23:12:27|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

LibreOffice のメニュー日本語化(Fedora22)

fedora22 のデフォルトで入るLibreOffice のメニューはなぜか日本語ではなく英語表示だ。
例えば、Calcを立ち上げて、
Tool -> Option -> Language Setting -> Language
をみると(すでにこの時点で英語表示)、
User Interface : English(USA)
Locale Setting : Japanese(Default)
になっていた。
User InterfaceをJapanese にしようとしたが、そもそも選択できない。日本語用の何かが入っていないらしい。
探してみると、

# dnf -y list libreoffice-*
メタデータの期限切れの確認は、2:04:48 前の Thu Dec 31 10:44:26 2015 に実施しました。
インストール済みパッケージ
・・・
利用可能なパッケージ
・・・
libreoffice-langpack-it.x86_64 1:4.4.7.2-1.fc22 updates
libreoffice-langpack-ja.x86_64 1:4.4.7.2-1.fc22 updates
libreoffice-langpack-kk.x86_64 1:4.4.7.2-1.fc22 updates
・・・

言語パッケージの日本語というのがあるので、インストールしてみる。

# dnf -y install libreoffice-langpack-ja

入った。Calcを立ち上げてみるとメニューが日本語に変わった。
めでたしめでたし。
  1. 2015/12/31(木) 13:15:33|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

fedora20で wineのインストール

Linux上でWindowsをエミュレートしてくれるというwineをインストールしてみた。
→エミュレートじゃなくてAPIで実行させるらしい。wineの略は”Windows Is Not an Emulator"だそうだ。

# yum -y install wine

これで関連しているのをインストールしてくれる。

Linux で Wine のインストールと種々

をみると、

# winetricks ie6

とやるらしいのだが、上記のコマンドはないらしい。
ちなみにWindowsアプリをインストールするには、Windowsのインストーラをダウンロードしておいて

$ wine mke399j.exe
$ wine winrar-x64-511b1.exe

とやればよい。しかも、ユーザ権限でできとる。
どこにインストールされているかというと、

/home/dodo/.wine/drive_c/Program Files
/home/dodo/.wine/drive_c/Program Files(x86)

というディレクトリを掘られていて、その下に置かれる。
root権限なしなので、なんと気楽にできるんだろ。
  1. 2014/08/11(月) 11:18:24|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

fedora19から20へネットワークによるアップグレードとその後のperlの不具合

備忘録。

昨日、fedora19から20へアップグレードした。
以下コマンド。
参考)How Can I Upgrade My System with FedUp?

# yum -y install fedup
# yum update fedup fedora-release
# fedup --network 20

時間はかかったが、再起動して問題なく立ち上がった。
めでたしめでたし・・・

と思ったのだが、今日perlのスクリプトを動かそうとしたらエラーで動かず。

$ perl -wc setdatau.pl
Perl API version v5.16.0 of List::Util does not match v5.18.0 at /usr/share/perl5/XSLoader.pm line 92.
Compilation failed in require at /usr/local/lib64/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/share/perl5/vendor_perl/HTML/Element.pm line 46.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/HTML/Element.pm line 49.
Compilation failed in require at /usr/share/perl5/vendor_perl/HTML/TreeBuilder.pm line 62.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/HTML/TreeBuilder.pm line 62.
Compilation failed in require at setdatau.pl line 8.
BEGIN failed--compilation aborted at setdatau.pl line 8.


OSアップグレードにともない、perlも5.16.xから5.18.2にアップされて、
その影響っぽい。
他のperl関連のコマンドも動いていないようだ。


$ cpan
Attempt to reload Scalar/Util.pm aborted.
Compilation failed in require at /usr/share/perl5/Safe.pm line 4.
BEGIN failed--compilation aborted at /usr/share/perl5/Safe.pm line 4.
Compilation failed in require at /usr/share/perl5/CPAN.pm line 56.
BEGIN failed--compilation aborted at /usr/share/perl5/CPAN.pm line 56.
Compilation failed in require at /usr/share/perl5/App/Cpan.pm line 218.
BEGIN failed--compilation aborted at /usr/share/perl5/App/Cpan.pm line 218.
Compilation failed in require at /usr/bin/cpan line 9.
BEGIN failed--compilation aborted at /usr/bin/cpan line 9.

$ perldoc List::Util
Perl API version v5.16.0 of List::Util does not match v5.18.0 at /usr/share/perl5/XSLoader.pm line 92.
Compilation failed in require at /usr/local/lib64/perl5/Scalar/Util.pm line 11.
Compilation failed in require at /usr/local/share/perl5/File/Temp.pm line 18.
BEGIN failed--compilation aborted at /usr/local/share/perl5/File/Temp.pm line 18.
Compilation failed in require at /usr/share/perl5/vendor_perl/Pod/Perldoc.pm line 1734.


More CPAN issues in Fedora 20
You must use fedup 0.8 to upgrade to Fedora 20(升级到Fedora20)

上記の記事を見ると、perlがインストールされたディレクトリを削除して
perlの再インストールとか言っているらしい。
確かに、yumのperl-CPANやperl-List-AllUtils等を部分的に
yum reinstall してみたのだが、状況はエラーは変わらず。
一応、yum reinstall perl-* もやってみたが全く変わらなかった。

ということで、/usr/local/以下にあるperl5を削除するので
下記コマンドを実行。


# cd /usr/local/lib64
# mv perl5 perl5_old_install # 名前を変更
# cd ../share
# mv perl5 perl5_old_install # 名前を変更
# yum install -y perl # yum でアンインストールしていないのでインストールは失敗する
# yum reinstall -y perl
# yum reinstall -y perl-*


すると、
$ perl setdatau.pl
が動くようになった!

ディレクトリ名を変更した下記ディレクトリには新たにインストールされたperl5はなかった。
/usr/local/share
/usr/local/lib64

どうも上記でなくて下記が使われてるので、
/usr/share/perl5
/usr/lib64/perl5
2つのパスで古いバージョンがlocalでそちらが先に読まれていた為にエラーだったのか。

  1. 2014/08/09(土) 15:18:55|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

明日はダービーだというのに

今日は重賞が無かったので馬券を買わなかった。一応テレビは見ていたけど。

というのも、PCのHDDの空き容量が残り少なくなっていて、そろそろ追加しなければと思い、
HDDを買って来た。そして、空き容量を確保すべく、データを新しいHDDに移行していたのだが、
13:30から始めて、未だに(22:00時点)30%にとどいていない進捗度合い。この調子だと、
ずっと動かし続けても明日の深夜1時過ぎになりそうなんだが・・・
1TBのデータ量ってそんなに時間がかかるものなのかと、ガックリするなぁ。

まあ、データコピーだけなのでPCの負荷はかかっていないから、他の作業もできるのだが、
上記の移行が終わった後、もう一回移行しないといかんので、先はまだまだ長い。
そろそろ予想するか。

テーマ:ひとりごとのようなもの - ジャンル:日記

  1. 2012/05/26(土) 22:36:39|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

西の空に光る星 北の空に光る星

「ミニノートPCをもって出かけよう」という宣伝文句につられて、
USB接続のGPSレシーバーを買ってみた。
ノートPCにGPSが付くことでナビゲーションも簡単にできるようになるだろう、
と軽い気持ちで買ってみたのだが。

なんだか、GPS用の衛星を検出できない!
まさか建物の中からでは駄目なのか?
電車の中でやってみた。
やっぱり、GPS用の衛星を検出できない!

レシーバー自体にいじれるところはないし、
インストールしたユーティリティソフトの設定をいじっても変わらないし、
どないすればええねん?

I-O DATA 高感度USB接続GPSレシーバー「NAVI CLIP(UMGPS/MF)」 UMGPS/MFI-O DATA 高感度USB接続GPSレシーバー「NAVI CLIP(UMGPS/MF)」 UMGPS/MF
(2009/10/10)
アイ・オー・データ

商品詳細を見る

テーマ:周辺機器 - ジャンル:コンピュータ

  1. 2010/11/30(火) 23:53:49|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

CPU交換

大したことには使っていないはずなのだが、
遅いと感じることに耐えられなくなってきた。
おそらく、Firefox3になったぐらいかと思うが、最近のアプリケーションは
マルチコアを前提に作られているのではないか?と思うくらい
CPUパワーを目いっぱい使ってるような気がする。

PCショップになんとなく行ってみて、なんとなく買ってきたという
衝動買いに近いものがある。ということで、Celeron D[シングルコア]から
デュアルコア(Pentium4だけど)に変更してしまった。
なんで、E5300かというと、現在使用中のマザーボードのFSBと
売っていたものと予算との釣り合うところということで。

速くなったか?といわれると、実はそうでもない(^^;
ただ、待たされている時間はあまり感じなくなったので、
それなりに目的は達せられているのではないかと。

次買うとしたら、マザーボードから入れ替えだからCore i7だろうか。
もう、えらい先のことのように思えるな。

インテル Boxed Intel Pentium Dual Core E5300 2.60GHz BX80571E5300インテル Boxed Intel Pentium Dual Core E5300 2.60GHz BX80571E5300
()
不明

商品詳細を見る

テーマ:自作・改造 - ジャンル:コンピュータ

  1. 2009/06/08(月) 23:29:11|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

V3→+-

Firefoxバージョンアップ案内のウィンドウが立ち上がった。
しかしよくみると、バージョン3へのものだった。
ちょっと悩む。

なぜかというと、マイナーバージョンなら大方のアドオンが使えるが、
メジャーアップになると使えないものが多くなる。
使えないと不便なものは結構多いからなぁ。タブミックスとかスクラップブックとか
リサイザブルフロムフィールドとか(カタカナで書くと不思議な機能に思える)。

しかし、3は噂によると最速のブラウザと言われているらしい。
それ以外に特長はあまり聞かないのだが、それだけで十分かもしれない。
今回のバージョンアップの知らせ方から察するに、今後2ではどうせアップされない
のだよなぁ。

ということで、この際だからアップしてみた。
おぉl!速いかも。
しかし、案の定アドオンが使えなくなっている。
前述の3つのうち2つも(T_T)
フィールドをリサイズできなくなるのは結構痛い。
タブの段組ができないのも不便だし。

しかし、今更後には戻れない。
新バージョンに対応するまで我慢するか・・・

テーマ:Firefox - ジャンル:コンピュータ

  1. 2008/08/26(火) 23:53:30|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

つながってホッとしているところ

つながりが悪くなったのは、今週の頭ぐらいだったと思うが、
そのときは回線状態がたまたま悪いのだと思っていた。

しかし、その後も一向に回復しなかったので、このままじゃ何もできん!
ということで、IE使ってみたり、LANカード替えてみたり、LANケーブル替えてみたり
モデムやルータを再起動させてみたりと、色々試してみた。
しかし駄目だったのだが、うちのネット環境はは○ahoo!のVoIPも使っていて、
そのターミナルアダプタ(TA)とモデムと分割タイプのやつがつながっている。
これを外して、モデム→PCと直接つないで見たところ、
見事にインターネットにつながることに!お前だったのか、諸悪の根源は。

先ほど、サポートセンターに電話したところ、モデム+TAを交換ということに。
交換品が来るまでは、TAなしでいいや。
というか、電話よりもネットにつながる方がメインだもんな。

ああ、これでなんとか馬券が買えるよ。
予想もいまからとりかかろうかなぁ。

テーマ:日々のつれづれ - ジャンル:日記

  1. 2008/05/31(土) 12:54:16|
  2. PC
  3. | トラックバック:0
  4. | コメント:0

ネットにつながらない。

いや、全くつながらないわけではないが、すごく遅い。
あまりに遅い(データ通信量が少ない)ので、タイムアウトしてしまい、
結局つながらない。あるいは、30分~1時間ぐらい待って
やっとレイアウトが崩れた画面が表示されたり。

うーん、この記事も上がるのか、
ダービーだというのに馬券買えるのか不安です。

・・・
と、昨日の夜書いたのだが、結局送信できず。
せっかく書いたのに悔しいから、上げとくよ。

テーマ:日々のつれづれ - ジャンル:日記

  1. 2008/05/30(金) 20:30:30|
  2. PC
  3. | トラックバック:0
  4. | コメント:0
次のページ

プロフィール

dodo

Author:dodo
いつのまにか夜が消えて
朝もやかかる頃
影を探しに戻らなくちゃ
夜が明ける前に

カレンダー

05 | 2017/06 | 07
- - - - 1 2 3
4 5 6 7 8 9 10
11 12 13 14 15 16 17
18 19 20 21 22 23 24
25 26 27 28 29 30 -

FC2カウンター

FC2ブログランキング

FC2ブログランキング

カテゴリー

最近の記事+コメント

リンク

このブログをリンクに追加する

月別アーカイブ

最近のトラックバック

ブロとも申請フォーム

この人とブロともになる

ブログ内検索

RSSフィード